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ImageJ

Introduction au logiciel 

Traitement et analyse d'image en astronomie 

Audrey Delsanti – Avril 2009

Installation d'Image J
Pour installer Image J sur votre ordinateur portable , ouvrez votre navigateur préféré et allez sur le site :

http://rsbweb.nih.gov/ij/index.html

cliquez sur le lien « Downloads ». Choisissez la version qui correspond à votre système d'exploitation.

• Pour Windows : le programme d'installation crée un ImageJ.exe

• Pour Mac OS X : double cliquez sur le fichier en « .dmg ». Un disque virtuel se monte. Faites glisser 
l'icône Image J vers le dossier Applications.

• Pour Linux, téléchargez l'archive tar.gz et tapez les commandes suivantes

gunzip ij123-x86.tar.gz

tar xvf ij123-x86.tar

cd ImageJ

./run

Vous pouvez ajuster la mémoire utilisée en allant dans le menu Image J :  Edit > Options > Memory

Attention :  si vous réglez la mémoire à plus de 75% de la mémoire disponible dans votre ordinateur, il  
risque d'y avoir des dysfonctionnements 

Installation de Plugins
Les  « plugins »  sont  des  fonctions  avancées  qui  ont  été  développées  par  des  programmeurs  ou  des  
utilisateurs et mis à la disposition de la communauté. Il y a des plugins déjà disponibles dans ImageJ, que  
l'on appelle Plugins internes  (voir le menu Plugins). On peut en installer d'autres selon nos besoins.

Allez sur le site : http://rsbweb.nih.gov/ij/index.html

et cliquez sur lien Plugins. 

Nous allons installer le plugin StackReg, qui permet de réaligner automatiquement un paquet d'images. 

• Recherchez la chaîne de caractères « StackReg » (voir  le menu Edition > Rechercher de votre  
navigateur) dans la page.

• Cliquez sur le lien trouvé : la page du plugin StackReg s'affiche. Les instructions indiquent qu'il faut  
d'abord installer le plugin TurboReg.

• Cliquez sur le lien  TurboReg pour obtenir la page sur ce plugin. Dans la section  « Download » 
cliquez sur le lien correspondant à votre système d'exploitation.

1

http://rsbweb.nih.gov/ij/index.html
http://rsbweb.nih.gov/ij/index.html


Stage Astro à l'école 2009                                                      UFE

• Vous récupérez un répertoire « TurboReg » qui contient des fichiers en « .class » : faites glisser ce 
répertoire dans le répertoire Plugins de Image J. Attention : la difficulté principale est de localiser 
ce répertoire Plugins.

Refaites les opérations ci-dessus avec le plugin « StackReg ». 

Relancez Image J : dans le menu Plugins >  vous verrez les noms des deux nouveaux plugins que vous  
venez d'installer.

Téléchargement des images du TP

Les images de ce TP sont disponibles sous forme d'une archive ZIP à l'adresse suivante :

https://upload.obspm.fr/get?k=1kMLr3HYMTOrkRQMSaO

• Si vous êtes sur une machine LINUX, ouvrir l'application Terminal

que l'on trouve sous le pied de Gnome (barre du haut)

Applications > Accessoires > Terminal

• Lancer l'environnement de travail ImageJ, (pour LINUX, en lançant la commande en ligne ImageJ dans la 
fenêtre du Terminal)

Exercice 1 : prise en main du logiciel 

Ouvrez l'image Jupiter01.jpg qui se trouve dans le répertoire Jupiter : File > Open …

Pour être certains de ne pas abîmer l'image originale : Image > Duplicate . Appelons cette nouvelle image 
JupiterTest.jpg. Vous pouvez fermer l'image Jupiter01.jpg

1. Annuler les opérations faites sur l'image

File > Revert permet de revenir à l'état initial du fichier image (au moment de l'ouverture et annule  
tous les traitements effectués). 

ATTENTION :  ce n'est  pas toujours possible,  c'est  pourquoi  il  est  plutôt  conseillé de dupliquer  
l'original et de travailler sur la copie.

Edit > Undo permet d'annuler la dernière opération. Attention encore, cette opération n'est pas  
toujours possible.

2. Propriétés de l'image

Observez les propriétés de l'image (caractéristiques en haut à gauche de l'image) : taille en pixels,  
type de codage des couleurs, taille du fichier.

Sous la barre des icônes d'ImageJ, observez les chiffres qui s'actualisent lorsque vous promenez la  
souris sur l'image : position du curseur en X et Y, valeurs R,G,B (dans le cas de cette image). Dans 
quel coin se situe l'origine (0,0) des positions ? 

Familiarisez-vous avec le menu Image :

Image > Type

Image > Show Info ...

Image > Properties ...
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3. Régler le contraste

Ouvrez la fenêtre de réglage du contraste : Image > Adjust > Brightness & Constrast

Jouez avec les différentes glissières. Pour revenir aux réglages initiaux, cliquez sur  Reset.  Pour 
laisser le programme choisir des réglages optimisés, cliquez sur Auto.

4. Afficher l'histogramme des valeurs de l'image

Affichez l'histogramme de l'image : Analyze > Histogram

Cela vous donne le nombre de pixels qui ont une valeur d'intensité donnée. Si l'on promène la souris  
sur l'histogramme, on obtient les valeurs. Par exemple, le fond étant noir, il y a beaucoup de pixels  
qui ont la valeur « 0 » (plus de 200 000).

5. Faire des statistiques sur l'image

Analyze > Measure

Vous obtenez une table avec des mesures : aire sélectionnée (en pixels, par défaut c'est  toute  
l'image), moyenne, valeur minimum, valeur maximum

Pour obtenir d'autres renseignements,  Analyze > Set measurements... , cliquez par exemple sur 
median

Refaites une mesure. Quelle est la valeur moyenne ? Quelle est la valeur médiane ? Pourquoi sont-
elles si basses ?

6. Tronquer une image

Nous allons tronquer l'image. 

cliquez sur l'icône « rectangle » de la barre d'outils (première icône)

dessinez un rectangle sur l'image, centré sur Jupiter avec une portion de ciel autour

Image > Crop

Refaites un histogramme. Refaites une mesure statistique. La moyenne a-t-elle changé ? Pourquoi ?

7. Faire des mesures à partir d'une sélection

Utiliser l'outil de sélection elliptique (deuxième icône de la barre d'outils). Dessinez un cercle qui  
englobe Jupiter. Faites les opérations suivantes et observez le résultat :

Analyze > Histogram

Analyze > Measure

8. Faire un graphique à partir d'une sélection

Cliquez sur l'icône « ligne » (quatrième icône). Tracez une ligne qui coupe Jupiter (et qui coupe du  
ciel de part et d'autre de la planète).

Analyze > Plot profile

Que remarquez vous ? Que repésentent les zones du graphique à «  0 » ? Que représentent les 
fluctuations ?
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9. Sauvegarder l'image

Fermez l'image JupiterTest. Si vous souhaitez la sauver, cliquez sur  Save. Le format proposé par 
défaut est TIF, qui ne compresse pas l'information (alors que JPEG va dégrader l'information).

Exercice 2 : travailler avec des piles d'images

1. Nous allons charger une série d'images de Jupiter.

Files > Import > Image Sequence...

Dans la boîte de dialogue, cliquez sur le nom de la première image de la série. Une autre boîte  
s'ouvre : La première case contient par défaut «  15 », c'est le nombre d'images dans le répertoire.  
Vous pouvez le modifier par exemple :

• tapez 10 dans « number of images »

• tapez 5 dans « starting image»

Le logiciel charge un cube qui contient 10 images à partir de la 5éme image du répertoire.

Faites coulisser l'ascenseur horizontal qui se trouve sous l'image pour accéder à toutes les images  
du cube.

2. Nous allons recouper la pile d'images

Comme dans l'exercice précédent, nous allons utiliser l'outil de sélection rectangulaire pour tracer un  
rectangle centré sur Jupiter. Puis Image > Crop.

Toute la pile a été recoupée. Nous allons la sauvegarder :  File > Save As > Tiff... . Appelons le 
fichier JupiterStack. 

3. Agir sur toute la pile

Vous pouvez régler la brillance et le contraste : Image > Adjust > Brightness & Constrast

Attention : si vous utiliser « Auto », le programme va vous demander s'il peut appliquer le réglage à  
toutes  les  images.  Ce  n'est  pas  toujours  judicieux.  Sauvegardez  l'original  avant  de  faire  cette  
opération.

Vous pouvez appliquer des opérations sur toutes les images du cube.

A partir de JupiterStack, vous pouvez utiliser le menu Process, par exemple : 

Process > Enhance contrast

Process > Sharpen

Le programme vous demande toujours si vous voulez appliquer à toutes les images.

Pour faire des statistiques sur toute la pile d'images : Plugins > Stacks > Measure Stack

4. Moyenner toutes les images du cube

Image > Stacks > Z project...

Choisir :  Average Intensity (attention toutes les options ne sont pas disponibles selon le format  
l'image :  dans ce cas, convertir l'image au format voulu par le menu Image > Type)

Par exemple si l'on veut additionner nos images RGB, il faut les transformer en N&B 8-bit.

Attention : si les images ne sont pas alignées entre elles la moyenne ou la somme peut donner un  
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résultat très décevant.

5. Réaligner les images automatiquement avant de les moyenner

Nous allons donc utiliser le Plugin  StackReg pour réaligner les images du cube. Sélectionnez le  
cube  des  images  de  Jupiter.  Puis  Plugins  >  stackreg  >  StackReg.   Choisissez  l'option 
« Rigid body»  puis  cliquez  sur  OK.  Le  programme passe  toutes  les  images  en revue.  Quand  
l'exécution est terminée, faites coulisser l'ascenseur horizontal sous le cube : que constatez vous ?

Maintenant vous pouvez moyenner les images de ce cube réaligné. Images > Stacks > Z Project...

6. Transformer des piles en images

Image > Stack > Stack to Images

Attention : le nom des images individuelles peut être le même que celui des images qui ont servi à  
créer le cube. Si vous avez fait des opérations sur ces images, iil vaut mieux faire cette opération  
dans un nouveau répertoire.

7. Transformer des images en piles

Ouvrez les images que vous souhaitez assembler en cube et faites I mage > Stacks > Images to 
Stack

8. Faire des opérations entre deux images simples 

Ouvrez les images Jupiter01.jpg et Jupiter 02.jpg, puis Process > Image Calculator

Sélectionnez Subtract pour soustraire l'image 15 de l'image 1. Que constatez-vous sur le résultat ?

 

9. Faire de l'arithmétique sur une image

Sélectionnez Jupiter01.jpg puis Process > Math > Divide

Entrez  la  valeur  « 10,5 »  :  nous  avons  divisé  la  valeur  des  intensités  par  10,5  sur  l'image  
Jupiter01.jpg (vérifiez avec Analyze > Measure).

Exercice 3 : le pré-traitement des images astronomiques

Comme on l'a vu dans le cours, pour une image astronomique donnée, il faut

• une série  de PLU (ou flat)  acquis  avec le  même montage optique,  instrument  non démonté et  
remonté,  et le même filtre

• une série de darks qui ont le même temps de pose que l'image astronomique (à noter que le dark  
contient l'offset : si on a des darks, on n'a pas forcément besoin de l'offset)

Nous allons traiter ici des images qui ont été acquises avec le télescope de 120cm de l'Observatoire de  
Haute-Provence. Pour cette caméra professionnelle refroidie à l'azote liquide, il n'y a pas d'effet notable du  
dark (c'est à dire que si l'on acquiert un dark de grand temps de pose, il sera très proche de l'offset) : on se  
contente donc de corriger de l'offset, qui est une image facile à acquérir (c'est une pose de 0s).

Pour vos images en webcam ou APN, il faudra plutôt utiliser le dark.
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Les images FITS

Les  images  dont  nous  disposons  ici  sont  au  format  FITS  :  c'est  le  format  utilisé  en  astronomie  
professionnelle. Un fichier FITS est composé de deux parties :

• un entête : qui contient l'information sur l'image au format texte (temps de pose, filtre, nom de l'objet,  
etc, stockés comme mots clefs). Vous pouvez voir le contenu de l'entête avec le menu  Image > 
Show Info 

• un tableau de valeurs de la taille du détecteur (si le détecteur fait 1024 x 1024 pixels, le tableau est  
de taille 1024x1024), chaque valeur correspond à l'intensité du pixel à la position X,Y : c'est l'image  
que l'on voit.

1. Création de l'offset « maître »

Nous  disposons  de  5  images  d'offset  qui  se  trouvent  dans  le  répertoire  OHP :  Offset01.fits à 
Offset05.fits

File > Import > Image Sequence...

Cliquez sur Offset01.fits. Dans la boite de dialogue, tapez «  5 » en face de Number of images et 
tapez « Offset » en face de File name contains. Vous obtenez un cube qui contient les 5 images 
d'offset.

• Réglez le contraste sur les images

• Inspectez visuellement chaque image du cube

• Faites des statistiques sur le cube : Quelle est la valeur moyenne de l'intensité sur chaque  
image ?

• Faites un histogramme sur une des images

• Faites un graphique à partir d'une coupe horizontale (sélectionnez l'outil ligne)

          

Faites  une  médiane  de  ces  5  images  :  Image  >  Stacks  >  Z  Project... et  choisir  Median. 
Sauvegarder le résultat dans le fichier Offset.fits.

2. Création du flat « maître »

Notre image scientifique a été prise avec le filtre V (visible). Nous devons donc acquérir des flats  
avec le filtre V. Nous disposons de 3 images FlatV01.fits à FlatV03.fits. Il y a plusieurs étapes pour 
créer le flat « maître »

1. Pour chaque image FlatV0X.fits , soustraire l'offset maître (Offset.fits)

2. Faire ensuite la médiane de ces images

3. Normaliser la médiane des images à 1

 

Chargez les 4 images FlatV dans un cube (comme précédemment)

• Réglez le contraste

• Inspectez-les visuellement :  regardez les différents artefacts. 

• Faites une statistique sur le cube : observez la valeur moyenne

Soustrayez l'image Offset.fits à ce cube :  Process > Image calculator. Refaites une statistique. 
Que constatez-vous ?

Faites une image médiane du cube Sauvegardez-là dans FlatMed.fits.
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Nous allons normaliser FlatMed.fits. Faites une statistique de l'image : quelle est la valeur médiane ?  
Nous allons diviser FlatMed.fits par la valeur de la médiane. Image > Maths > Divide. Dans la boîte 
de dialogue, tapez la valeur de la médiane. Sauvegardez l'image sous FlatV.fits

Nous avons notre flat maître ! Vérifions que la médiane est autour de 1 sur FlatV.fits (faites une 
mesure statistique). Faites une coupe horizontale (outil de sélection ligne) et affichez le graphique  
correspondant.

3. Traitement de l'image scientifique 

Maintenant que les fichiers Offset.fits et FlatV.fits sont prêts, il ne reste plus qu'à traiter l'image selon  
la formule :

                              ImageV Corrigée=
ImageV−Offset

FlatV
 

Ouvrez le fichier M51_V.fits. Ouvrez les fichiers Offset.fits et FlatV.fits 

Utilisez le menu Process > Image calculator pour appliquer la formule ci-dessus et sauvegardez 
l'image  finale  sous  le  nom  M51_VCorr.fits.  Comparez  les  deux  images,  originale  et  corrigée 
(graphique en coupe, statistique, etc).

Vous venez de réaliser le traitement que tous les astronomes professionnels appliquent à 
leurs données en imagerie ! Maintenant, à vous de réfléchir aux autres étapes de traitement, en  
fonction de votre projet.

Exercice 4 : Détermination de la taille d'une protubérance solaire.

Objectif : déduire de l'image du soleil  qui vous est proposée, la taille de la protubérance.  C'est à dire  
« traduire » une distance en pixels (picture element) sur l'image donnée, en distance physique (en km). 

1. Ouvrez dans ImageJ, l'image située dans le répertoire « Soleil »,  Sun.gif. grâce au  menu File > 
Open …

2. Remarquez : la souris positionnée dans la fenêtre de l'image, activez le menu contextuel (bouton  
droit de la souris, ou bien Ctrl click), un menu déroulant apparait, dans lequel vous avez un certain  
nombre de commandes à votre disposition.

3. Dupliquez l'image et passez-là en type 8-bit (N&B) Image > Type. Fermez l'image originale.

4. Avec l'outil Lignes, tracez le diamètre du Soleil et regardez sa valeur en pixels affichée sous la barre  
des icônes length = (donnée en pixels).

5. Analyze > Set Scale, vous permet de renseigner la valeur en km du diamètre solaire que vous  
venez de tracer avec l'outil « Lignes » (Indication : diamètre solaire = 1,4 millions de km).

6. Mesurez maintenant la valeur de la hauteur de la protubérance solaire (outil Ligne). Lisez la valeur 
de cette hauteur sous la barre des icônes. Cette fois-ci elle est affichée en valeur physique (en km  
ou MiKm selon ce que vous avez choisi). Quelle est cette valeur ?

7. Analyze > Tools > Scale Bar ... vous permet de tracer dans la fenêtre de l'image la barre du facteur  
d'échelle (par exemple faites une barre de 500 000 km). Cliquez d'abord sur l'endroit où vous voulez  
placer la barre avant de lancer la commande.

8. Pour obtenir de la documentation et de l'aide en ligne : Help > Documentation ... , 
pour le menu Analyze, par exemple vous serez dirigé vers
 http://rsbweb.nih.gov/ij/docs/menus/analyze.html
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