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Logiciel de calcul, d’analyse et de traitement d’images 
ImageJ est écrit en Java par le National Institute of Health (NIH).

ImageJ fonctionne selon deux modes:
    * en tant qu'applet dans un navigateur web,
    * en tant qu'application sur n'importe quelle plate-forme supportant Java.
Vous pouvez le télécharger sur votre ordinateur à partir du site 
http://rsb.info.nih.gov/ij/download.html.
La première version, NIH-image, écrite en langage Pascal a été développée pour le système 
d'exploitation Macinstosh. 

• ImageJ est maintenant écrit en Java et est multiplateforme (Mac, Windows, Linux). 
• C'est un logiciel du domaine public («disponible gratuitement» ; «domaine public» est un 

terme légal qui signifie que le logiciel n'est pas «soumis au copyright»), le code source est 
libre et disponible.
Des mises à jour de ce logiciel sont régulièrement mises à disposition des utilisateurs sur le 
site d'ImageJ, ainsi que de la documentation des plugIns et des macros commandes.

• ImageJ permet de lire de nombreux formats de fichiers , en particulier, le format de données 
FITS très utilisé en astronomie (Flexible Image Transport System).
Manipulation scientifique d'images :

L'auteur d'ImageJ est, 
Wayne Rasband (wayne@codon.nih.gov)
Research Services Branch, National Institute of Mental Health, Bethesda, Maryland, USA. 
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Résumé des fonctions offertes par IJ 
Multiplateforme :

ImageJ (développé en langage Java) tourne sur les ordinateurs équipés des systèmes d'exploitation 
Linux, Mac OS 9, Mac OS X, Windows, et le Sharp Zaurus PDA. 

Logiciel Libre :

ImageJ et son code source Java sont librement distribués et sont dans le domanie public, pas de 
licence obligatoire

Communauté d'utilisateurs:

Il existe une grande communauté internationale d'utilisateurs d'ImageJ. Plus de 1500 utilisateurs et 
développeurs sont inscrits à la liste de diffusion ImageJ. 

Macros:

Pour automatiser un ensemble de tâches et créer des outils de traitement de données personnalisés, 
on utilise les Macros commandes. Une Macro est générée automatiquement, grâce à la commande 
« Plugins > Macros > Record… » lors de l'utilisation des commandes d'ImageJ. Plus de 200 Macros 
sont disponible sur le site web d'ImageJ. 

Plugins (plugiciel, extension des possibilités, additif) :

Le développement de plugins en java permet d'étendre les possibilité de traitement des données 
d'ImageJ. ImageJ possède un éditeur intègré et un compilateur Java ; il y  plus de 300 plugins 
disponibles pour ImageJ.

Toolkit (Boîte à outil) :

Les bibliothèques de classes java d'ImageJ peuvent être utilisées pour développer des petites 
applications de traitement d'images (applets Java).

Vitesse de calcul :

ImageJ, programme purement java de traitement d'image, est le plus rapide. Il peut filtrer une image 
2048x2048  in 0.1 seconds (*), soit 40 million pixels par seconde ! 

Types de données :

8-bit niveaux de gris ou couleur indexéesor indexed color, 16-bit unsigned integer, 32-bit floating-
point and RGB color. 

File Formats :

Permet de lire et enregistrer de nombreux formats de fichiers comme le TIFF (uncompressed) ou 
bien les données brutes (raw data),. GIF, JPEG, BMP, PNG, PGM, FITS and ASCII. Permet 
d'ouvrir les DICOM. Via une URL, permet d'ouvrir TIFFs, GIFs, JPEGs, DICOMs et les données 
brutes. Ouvrir et fermer de nombreux autres formats de fichiers en utilisant des plugins.

Affichage d'images (Image display):

ImageJ propose des outils pour zoomer (de 1 à 32, de 32 à 1), pour faire défiler l'image dans la 
fenêtre d'affichage. Toutes les fonctions d'analyse et de calculs sont applicables à n'importe quel 
facteur de zoom.

Selections :

Des outils de sélection d'aires rectangulaire, elliptique, circulaire, irrégulière ; sélection par création 
de lignes (droites, brisées, libres, segmentées), de points. ImageJ permet de gérer les sélections, les 
éditer, les enregister, les transférer sur une autre image. on peut effecteur des opérations, des 
mesures, des statistiques sur les sélections. ROI = Region Of Interest (Région d'Intérêt).



Amélioration des images, Image Enhancement:

Détection de contours, accentuation (plus net), mediane, filtre et seuillage sur les images 8 bit 
niveaux de gris , RGB. Ajustement interactif de la lumière et contrastre sur les images 8, 16 and 32-
bit. 

Opérations géométriques :

Extrait d'image, modification de l'échelle, modification de la taille, rotation, retournement vertical 
ou horizontal.

Analyse desz données : statistiques et mesures :

Mesure d'aire, moyenne, déviation standard, calcul du min et du max. mesure de longueur et 
d'angles. Utilisation des unités physiques (mm, km …) . Calibration, génération d'histogramme et 
de tracés graphiques.

Editing :

Couper, copier ou coller images ou sélections. Plusieurs modes de collage : AND, OR, XOR or 
"Blend". Possibilité d'ajouter sur l'image du texte, des flèches, rectangles, ellipses, polygones … 

Calculs sur le codage couleur : Color Processing:

Séparation d'une image 32-bit couleur en composants  RGB ou HSV. Fusion d'images 8bit en une 
image indexée couleur. Convertion d'une image RGB image en une image couleur 8-bit indexée. 
Application de palettes de pseudo-couleurs à des images niveaux de gris. 

Stacks:

Affichage d'images en tant que pile d'images, "stack" dans une seule fenêtre avec curseur 
permettant de faire défiler les images.. Calculs, statistiques … une seule commande pour traiter 
l'ensemble de la pile. On peut également ouvrir les images d'un dossier en tant que pile. Sauvegarde 
des piles en tant que multi-images TIFF, animation QuickTime …



Environnement de travail
Une fois le programme ImageJ lancé , 

• Une barre de menus et de sous-menus . 

! Pour travailler sur des fichiers existants, pour créer des fichiers image, animation ou 
texte, éditer, effectuer des calculs …

• Une barre d'outils de tracés, de manipulations, sélections…

• Lorsque vous ouvrez un fichier, l'image numérique est affichée dans une fenêtre ; au dessus 
de l'image les caractéristiques suivantes sont affichées :

! taille en pixels, codage couleur, poids de l'image



Outils et opérations de base
Dans la fenêtre nommée ImageJ vous avez à votre disposition une série d'outils (barre d'outils) de 
tracés, de sélections spatiales, de codage, coloration des pixels ... :

Sélections

Les 4 premiers boutons de la barre d'outils sont des outils de sélection. Ils vous permettent de 
sélectionner une aire : zone de pixels rectangle (carrée), ovale (ronde), polygone ou à « main 
libre ». 

• Grâce aux menus Image, Process, Analyse ... 

• Vous pourrez appliquer un traitement particulier aux pixels de la zone sélectionnée (ROI : 
Region Of Interest) : effectuer un calcul, des mesures, une analyse, une copie ....

• Sous les outils, dans la barre d'outils vous pouvez voir s'afficher la position du pixel pointé 
dans l'image et sa valeur.

•

Tracés

Le bouton suivant permet de tracer des droites de différents types : droites , droites segmentées ou à 
main libre :

• En fait 3 boutons se cachent derrière ; ils sont obtenus avec « clic-droit » : Straight – 
Segmented - Freehand.

• Si « double-clic » sur l'outil de tracé choisi, vous obtenez une boîte de dialogue pour choisir 
la largeur du tracé.

• Si clic hors du tracé, il disparaît.



• Pour faire une sélection multiple, ou plus élaborée il suffit de maintenir une touche :

! pour ajouter : la touche Majuscule (Shift) en même temps que l'on fait d'autres 
sélections,

! pour retrancher : la touche alt (option) en même temps que l'on fait d'autres sélections.

• « ctrl D » ou menu Edit > Draw (ou menu contextuel avec le bouton droit de la souris) pour 
tracer les lignes de façon permanente.

• Il est possible de mémoriser les différentes sélections effectuées dans l'image : 

! menu Edit > Selection > Add to Manager 

! menu Analyse Tools > ROI Manager ...

Réticule (crosshair)

Le réticule vous permet d'indiquer un point de l'image. À chaque clic sur un endroit de l'image, les 
coordonnées (x,y,z) du pixel et sa composante d'intensité (valeur de 0 à 255) sont enregistrées dans 
la fenêtre de données (data window).

Remarque : pour un pixel (x,y,z), ses coordonnées spatiales (x,y) dans l'image z (slice numéro z) de 
la pile d'images (stack)

Dans le cas des images codées en RVB, ayant donc 3 composantes d'intensité, dans le rouge, le vert 
et le bleu, le vecteur value=(r, g, b) des intensités est affiché dans la fenêtre des données.

Baguette magique (wand tool)

Cet outil trouve automatiquement les bords d'un objet et en trace la forme. Cet outil fonctionne 
mieux avec des images au fort contraste. (Voir seuillage = thresholding).

• Placez la baguette magique à gauche d'un « bord », cliquez et l'algorithme de calcul va 
chercher à droite du pixel concerné la présence d'un « bord » et va tracer un contour le long 
du bord de l'objet jusqu'à ce qu'il se retrouve au point de départ.

• Pour étendre ou diminuer une sélection il suffit de maintenir une touche :

! pour ajouter : la touche Majuscule (Shift) en même temps que l'on fait d'autres 
sélections,

! pour retrancher : la touche alt (option) en même temps que l'on fait d'autres sélections.

Texte

Vous permet d'éditer du texte (commentaires, légendes, titres ...) sur l'image.

• « Double clic » sur l'outil texte affiche une boîte de dialogue de choix de la police de 
caractères, taille et style.

• « Clic simple » sur le bouton texte, une boîte apparaît, placez-la où vous le souhaitez , entrez 
le texte, et pour le tracer définitivement « ctrl D » ou menu Edit > Draw (ou menu 
contextuel avec le bouton droit de la souris).

Loupe

Pour « zoomer » :

• « clic gauche » augmente la taille de l'image

• « clic droit » réduit la taille de l'image



Défilement (scolling tool)

L'outil, petite main, permet dans le cas où l'image est plus grande que la fenêtre de visualisation des 
données à l'écran, de déplacer l'image et d'en voir les parties cachées.

Pipette (color picker)

Cet outil vous permet de définir les couleurs de premier plan (texte) et d'arrière plan en 
sélectionnant une couleur de l'image avec la pipette.

• La couleur de l'outil change lorsque vous sélectionnez un pixel de l'image : la pipette prend 
la couleur  de premier plan et le cadre la couleur d'arrière plan (fond).

• Dans le cas d'une image codée en RVB, le vecteur des valeurs des intensités (R,V,B) sont 
affichées sous la barre des outils lorsque vous cliquez sur un pixel de l'image.

• « Double clic » sur l'outil pipette ouvre une fenêtre de la table des couleurs (nommée CP), 
vous pouvez sélectionner les couleurs de votre choix pour les premier plan et arrière plan, à 
la souris, en cliquant dans la palette.



Traitement d'image (image processing)
Quelques exemples de techniques de traitement des données (image affichée) réalisables. ImageJ 
est adapté à l'analyse des données, d'autres logiciels de traitement des images (Gimp, Photoshop ....) 
seront plus adaptés à la mise en page, la retouche,…

Attention : il est très important de travailler sur une copie de l'image originale (bien la sauvegarder 
avant toute manipulation).

• Undo menu Edit > Undo, pour annuler la dernière action,

! attention cette action n'est pas toujours possible.

• Revert menu File > Revert pour revenir à l'image originale,

! attention cette action n'est pas toujours possible.

• Crop menu Image > Crop permet de retailler une image, avec l'outil rectangle, sélectionnez 
la région de l'image que vous souhaitez conserver.

• Clear Outside menu Edit > Clear Outside avec un outil de sélection entourez la région qui 
vous intéresse, 

! Clear Outside va effacer tout ce qui est à l'extérieur, 

! Clear va effacer l'intérieur de la région sélectionnée.

• Enhancing Brightness and Contrast menu Image > Adjust vous permet d'améliorer la 
luminosité et les contrastes de l'image. 

• Removing Noise (enlever le bruit) menu Process > Noise > Despeckel ou Process > Filters 

> Median

• Rotating an Image menu Image > Rotate, puis sélectionnez le type de rotation.

• Converting to Greyscale menu Image > Type > 8 bit convertit l'image en 256 niveaux de 
gris de 0 noir à 255 blanc.

• Thresholding (Binary Contrast Enhancement) seuillage, utilisé pour la détection de 
contours, le comptage  de particules ou pour les mesures.

! Image > Adjust > Threshold utilise un curseur pour ajuster la valeur de seuillage.



ImageJ propose plusieurs fonctions de filtrage dans le menu Proces. Quelques exemples  :

• Process > Filters > Convolve   ( Gaussian Blur, Median, Mean ....)

! une boîte de dialogue permet de paramètrer le calcul.

• Process > Math > Add, Substract, Multiply ...

• Process > Image Calculator 

! une boîte de dialogue permet d'effectuer des opérations mathématiques de soustraction, 
multiplication, division ... entre deux images (ou piles),

! en astronomie ceci est très pratique pour réduire les données (soustraction du « dark 
field » et division par le « flatfield ».

• etc



Mesurer et compter des objets
• De nombreuses fonctions de mesures : Area, Min/Max, Mean, Standard deviation, etc, 

pourront être appliquées à une image (ou aux images d'une pile)

• Mesurer la distance entre des points : Tracez un trait entre deux points, sous la barre des 
outils s'affichent leur distance en pixels et l'angle formé par rapport à l'horizontale.

• Définir l'échelle de mesure : tracez un trait entre deux points dont vous connaissez la 
distance. Le menu Analyse > Set Scale ouvre une fenêtre de dialogue qui affiche la distance 
en pixel, vous n'avez plus qu'à entrer la distance connue dans l'unité choisie. Le bouton 
« global » permet de définir cet échelle (par ex : cm / pixels) à toutes les images affichées.

• Mesures d'aires : Entourez, grâce à un des outils de sélection, une région de l'image. Ou 
bien utilisez le Menu Analyse > Analyse Particules.

! Analyse > Measure affiche une fenêtre « Results »contenant les mesures (moyenne, 
déviation standard, min, max ...), une nouvelle barre de menus permet de sauvegarder, 
éditer, sélectionner d'autres mesures à réaliser.

! Le menu Analyse > Set Measurements permet de définir les mesures que l'on désire 
effectuer sur l'image ou sur une ROI.



Échelle et codage couleur 
En plus de l'outil Texte qui vous permet de légender vos images numériques, ImageJ vous donne la 
possibilité de placer dans la fenêtre d'affichage de l'image les informations :

• d'échelle (ex : « km/pixels ») : grâce au menu Analyse > Tools > Scale Bar ...

• de codage des couleurs (affichage de la LUT utilisée) : grâce au menu Analyse > Tools > 

Calibration Bar ...

•



Enregistrement des données traitées
Les images obtenues à partir d'appareils photo numériques sont souvent au format JPEG (jpeg ou 
jpg), ce format de compression effectue à chaque ré-enregistrement une perte d'information. 

Chaque fois que vous ouvrez une image, la manipulez puis la re-sauvegardez, elle se dégrade.

 Il vaut donc mieux utiliser le format sans perte de qualité TIFF sans compression  (tif ou tiff) 
pendant le travail de traitement des données de l'image avec ImageJ.

• Lorsque vous enregistrez, ou lorsque vous appuyez sur la touche S du clavier, 
l'enregistrement se fait en tiff par défaut (fichier dont l'extension du nom est .tif), une fenêtre 
de dialogue « Save as TIFF » s'affiche.

ImageJ peut lire et créer des fichiers dans de nombreux formats : TIFF, GIF, JPEG, BMP, PGM, 
RAW, AVI, QuicTime, text ... et le format FITS.



Pile d'images : Stack et slices
Les piles dans ImageJ permettent le traitement par lot : vous pouvez effectuer un traitement 
spécifique à l'ensemble des images contenues dans la Pile. Une pile peut contenir des données 
évoluant dans le temps …

Vous pouvez lire des animations (Gifs animés, avi, quicktime), travailler et enregistrer une séquence 
d'images avec ImageJ, les « Images Stack » (Pile d'images) permettent d'appliquer une action sur 
toutes lesimages en même temps, ou juste sur l'image du dessus de la pile.

Chacune des images de la pile est appelée « Slice ». Un curseur permet de passer d'une image à 
l'autre et de les faire défiler.

• File > Import > Image Sequence ... permet de charger dans une pile les fichiers d'un 
répertoire. Seule la mémoire vive disponible est une limite au chargement de fichiers dans la 
pile.

• File > Import > QuickTime

• File > Open permet de lire des fichiers au format FITS contenant plusieurs images (2D, 1D 
...), des cubes de données (3D).

• Les manipulations des images pourront se faire sur une image particulière ou sur toutes les 
images à la fois dans la pile.

! Vous pourrez appliquer un traitement numérique  à toutes les images (« feuilles ») de la 
pile en une seule commande.

! Les données pourront être projetées le long d'un axe choisi, 

! On peut effectuer des coupes et leur tracé, un hitogramme, des mesures ... 

• Image > Stacks > Images to Stack, créez une pile à partir des images affichées à l'écran 

• Image > Stacks > Stack to Images, sortez les images de la pil et afficez les comme des 
images individuelles à l'écran



Macros
Il est possible de créer des macro-commandes d'ImageJ, un langage de script permet d'automatiser 
une succession d'actions. 

Une fonction « Record » d'enregistrement des actions menées dans ImageJ simplifie la tâche et 
permet d'écrire simplement une macro.

Vous trouverez de nombreuses Macros à télécharger sur les sites web.



Plugins 
Plusieurs centaines de plugins sont à votre disposition sur le site d'ImageJ. Les plugins sont très 
faciles à installer : simplement déposer les plugins dans le dossier ImageJ/plugins.

Les plugins sont en général écrits en Java, mais d'autres langages tels que JPython sont aussi 
supportés.

Installer, par exemple, le pack de plugins 

• astronomy   http://www.astro.physik.uni-goettingen.de/~hessman/ImageJ/  

• de thevenaz : http://bigwww.epfl.ch/thevenaz/stackreg/

et http://bigwww.epfl.ch/thevenaz/turboreg/

• de tony collins http://ijm2.ijm.jussieu.fr/imagerie/Ressources/ImageJ/Plugings

D’autres plugins sont disponibles, par exemple :

http://rsb.info.nih.gov/ij/plugins/index.html

http://ij-plugins.sourceforge.net/

http://sourceforge.net/project/showfiles.php?group_id=44711

http://www.pp.rhul.ac.uk/~cowan/astro_course.html

http://www.astro.physik.uni-goettingen.de/~hessman/ImageJ/
http://www.pp.rhul.ac.uk/~cowan/astro_course.html
http://sourceforge.net/project/showfiles.php?group_id=44711
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http://ijm2.ijm.jussieu.fr/imagerie/Ressources/ImageJ/Plugings
http://ijm2.ijm.jussieu.fr/imagerie/Ressources/ImageJ/Plugings
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http://bigwww.epfl.ch/thevenaz/stackreg/
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Le format FITS
Flexible Image Transport System (FITS) est très répandu en astronomie et en astrophysique. Il 
permet la sauvegarde de données de type entier ou réel structurées en tableau à plusieurs 
dimensions. Il est souvent utilisé pour sauvegarder également d'autres données, comme le spectre, 
des listes de photons, des cubes de données, et bien d'autres choses encore. 

Un fichier FITS peut contenir plusieurs extensions, et chacune de celles-ci peut contenir des 
données. Par exemple, il est possible de sauvegarder dans le même fichier FITS des images à la fois 
dans le domaine des rayons X et dans celui de l'infrarouge.

• Pour visualiser les images au format FITS : 

! DS9, ImageJ (logiciels en licence libre), HOU (SasaJ) et bien entendu les logiciels 
professionnels de l'astronomie tels que midas, iraf, idl ...

! voir http://fits.gsfc.nasa.gov/

Les fichiers images numériques au format FITS comportent : 
• un entête ou header, contenant des informations sur l'image, 
• puis le flux de chacun des pixels en format binaire. 

http://fits.gsfc.nasa.gov/
http://fits.gsfc.nasa.gov/
http://fits.gsfc.nasa.gov/


Unité de capacité de mémoire
1bit = la plus petite quantité d’information utilisable par un microprocesseur (0 ou 1).
1 octet (ou byte ou caractère) = 8 bits
1 kilo-octet (Ko) = 1024 octets
1 méga-octet (Mo) = 1024 Ko
1 giga-octet (Go)  = 1024 Mo
1 téra-octet (To) = 1024 Go

Remarque :

Pour télécharger les fichiers nécessaires aux TDs  à partir du  « ftp anonyme de l'Observatoire » il 
faut entrer dans le champ adresse du navigateur, l'url :

ftp://ftp.obspm.fr/

répondre aux questions :

• utilisateur (login) : anonymous

• mot de passe : prenom.nom@obspm.fr   (votre adresse mail)

puis dans le réperdoire outgoing vous trouverez le répertoire DUOP

marie-france landréa
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